Vulnerabilidades en NextGen ataca a WordPress

Las graves vulnerabilidades en NextGen ataca a WordPress. Mas de 800.000 páginas se han visto afectadas por las vulnerabilidades del Plugin NextGen de Imagely.
Esta entrada fue publicada en Investigación , Vulnerabilidades , Seguridad de WordPress el 8 de febrero de 2021 por Ram Gall.
A mediados de diciembre de 2020, el departamento de Ciberseguridad del equipo de WebFensa de Bomontec investigó dos vulnerabilidades de falsificación de solicitudes entre sitios (CSRF) del plugin NextGen Gallery , un Plugin de WordPress con más de 800.000 usuarios. Una de estas vulnerabilidades, de gravedad crítica, podría conducir a la ejecución remota de código (RCE) y secuencias de comandos almacenadas entre sitios (XSS). La ejecución de estas vulnerabilidades podría llevar a la toma de control del sitio, redireccionamientos maliciosos, inyección de spam, phishing y mucho más.

Esto provocó que las vulnerabilidades tuvieran una difusión completa en pocos días. En la tercera semana de diciembre de 2020 Imagely publicó la versión parcheada, 3.5.0, el 17 de diciembre de 2020.

 

Los clientes del servicio de WebFensa de Bomontec fueron avisados con reglas de firewall para protegerse de estas vulnerabilidades el 14 de diciembre de 2020.

 

1ª Vulnerabilidad

Descripción: Falsificación de solicitudes entre sitios (CSRF) que conduce a XSS y RCE a través de la carga de archivos y plugins LFI

afectado: Plugin de galería de WordPress – Complemento de galería NextGEN

Slug: nextgen-gallery

Versiones afectadas: <3.5.0
ID de CVE : CVE-2020-35942
Puntaje CVSS: 9.6 (CRÍTICO)
Vector CVSS: CVSS: 3.0 / AV: N / AC: L / PR: N / UI: R / S: C / C: H / I: H / A: H
Versión completamente parcheada: 3.5 .0

 

2ª Vulnerabilidad

Descripción: Falsificación de solicitudes entre sitios (CSRF) que conduce a la carga de plugins
afectado: Plugin de la galería de WordPress – Complemento de la galería NextGENSlug: nextgen-gallery
Versiones afectadas: <3.5.0
ID de CVE : CVE-2020-35943
Puntaje CVSS: 8.8 (ALTO )
CVSS Vector: CVSS: 3.0 / AV: N / AC: L / PR: N / UI: R / S: U / C: H / I: H / A: H
Versión completamente parcheada : 3.5.0

 

En el servicio de WebFensa de Bomontec está incluido el análisis diario de estas y otras tantas vulnerabilidades por parte de nuestro departamento de Ciberseguridad.

Si conoce a alguien que usa este Plugin(NextGen de Imagely) en su web, envíele esta noticia para ayudar a mantener sus webs protegidas, ya que, se trata de vulnerabilidades críticas y de alta gravedad que pueden llevar a la toma de control de la web por completo.

 

Desde el área de ciberseguridad de Bomontec trabajamos para proteger su patrimonio digital.